Jump to content

Greetings,

We have done a forum update that changed and added a lot of new and exciting features. During this update, we had to remove and rebuild the KICentral themes "Bright" and "Dark." Therefore your theme selection has been reset and you will need to reselect your theme again.

-Dane

malem

Forum software upgrade

Recommended Posts

Tonight, we're upgrading the forum software to IPS Community Suite 4. This requires a database conversion, so KIC will be unavailable starting around 8:00pm. We'll get everything back up ASAP & by Tuesday morning.

The new software includes a number of changes from the IPB 3.x series we've used for years. Most notably, a new responsive mobile theme will offer many improvements when viewing the forum with the mobile website. Another notable change is an improved editor that eliminates the "BBCode switch". Advanced users can still type BBCode manually, if they prefer that to the editor buttons.

If you notice problems or have questions after the upgrade, feel free to send me a PM or post in this thread.

Share this post


Link to post
Share on other sites

Just a bump to remind everyone that this is happening in a couple hours.

 

Full backups are being made, but it is possible that a small number of posts from tonight will be lost if we have to restore a database backup. If you're working on an amazing post tonight that you don't want to lose, I'd recommend copying it into an e-mail, Google Doc, text file, etc.

Share this post


Link to post
Share on other sites

After manually correcting about 50 different database errors, everything should be back online now. Let me know if you have problems.

The forum is currently loading very slowly when logged in. This might be a temporary issue related to automated tasks that are continuing after the upgrade. If it continues, either Dane or I will look at it tomorrow (today).

Thanks for your patience!

Share this post


Link to post
Share on other sites

(Double post because previous post was liked)

Also, why am I unable to enable notifications for when my posts are liked? It says that the administrator has disabled that option. That's pretty much the only thing I used notifications for.

(On a side note, I find it rather interesting that the current contents of my notifications list consist of what appears to be the notifications I received during the previous failed attempt at this upgrade a year and a half ago. :P)

Share this post


Link to post
Share on other sites

^^ That notice is for the web notifications API; see https://developer.mozilla.org/en-US/docs/Web/API/notification

I believe IPB uses it to push notifications on mobile devices when the mobile website is loaded, but I'm not sure if it's enabled/working.

^ Some settings will need to be tweaked in the coming days. There currently seem to be a few issues with the "like" system.

Share this post


Link to post
Share on other sites
6 hours ago, Gannersdaddy said:

Seems good so far at my end.  Looks a little different, but not in a bad way.  Logon on was fine.  Trying a message with file attachment now.

 

It keeps giving me this notification.

Untitled.jpg

That is so it can give notifications that you have enabled, like a followed thread and PM's that you get. They will popup on the page as a preview. Otherwise you will just get the notice on the top bar like before.

Share this post


Link to post
Share on other sites
1 hour ago, TheBEASTunchained said:

Looks like there's no way to view the desktop version on mobile devices anymore? 

The new version uses a single responsive theme rather than a separate mobile theme, so there's nothing to switch to.

You can use CSS tweaks on your phone if you want to make it look like it does on a desktop. If people are interested, I could put instructions somewhere.

Share this post


Link to post
Share on other sites

Malem also wanted to bring out there is a problem where it wont let me change my background image when i try to click the option it immediately goes back up.

Hopefully I'm not repeating something that has been mentioned. 

*Edit the problem has been resolved no worry 

Edited by Xdog42
Problem/Error has been fixed

Share this post


Link to post
Share on other sites

Can I request that something be done with the "interests" on the user card on each post on the forums? The inclusion of that is causing massive amounts of whitespace between posts for certain users. As an example, silver2005 is one such user with a lengthy interests section, and the problem can be clearly seen on this page of the NFL thread. My preference would be to simply not show that field on the threads, so that users like silver2005 can leave it as it is, but if not that, then it needs to have a character limit enforced to prevent these massive amounts of whitespace.

Share this post


Link to post
Share on other sites

Working on the Tapatalk issues now, just keep posting in here with issues that you find. Started this forum in 2003 and this was the largest and most difficult to install in forums software IPB ever put out.

The park photos will be coming back for backgrounds, just working on more of the technical stuff now.

Share this post


Link to post
Share on other sites

So, I'm officially on the desktop version and so far, so good! :D 

And KDD, I meant the auto-emojis. At least when I last used mobile, the only KIC emojis I could use were the ones I knew how to create myself (Ex: : + D turns into :D) . I couldn't choose from a drop-down on mobile like I can now.

 

EDIT: So, quick thing; I've noticed that when I try to change the background photo, the window to do so quickly closes (and I can't do so); also, are signatures gone or are they still being retrieved/updated?

Share this post


Link to post
Share on other sites
44 minutes ago, Dane said:

Working on the Tapatalk issues now, just keep posting in here with issues that you find. Started this forum in 2003 and this was the largest and most difficult to install in forums software IPB ever put out.

The park photos will be coming back for backgrounds, just working on more of the technical stuff now.

Glad you are working on this. It's nice to access all forums through one app.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×